Back to overview
Degraded

We are experiencing degraded performance on end to end calling

Dec 12 at 12:57pm GMT
Affected services
Synthflow API
End to end calling

Resolved
Dec 12 at 02:59pm GMT

RCA

On December 12, 2025, starting at 13:58 CET, we experienced a brief service interruption caused by a DNS management policy change that led to unintended DNS record removals. The issue was quickly identified, rolled back to a safer update-only (upsert) behavior, and all DNS records were restored, with full service recovery by 14:20 CET. We have since strengthened safeguards around DNS policy changes, including clearer policy separation and additional monitoring, to prevent similar incidents in the future.

Updated
Dec 12 at 01:18pm GMT

We have identified the issue and resolved it. We will share an RCA shortly, apologies for the inconvenience.

Created
Dec 12 at 12:57pm GMT

We are currently seeing an evaluation in call failures. We are investigating the cause.