Back to overview
Maintenance

Infrastructure Optimization

Mar 23, 2026 at 12:00pm UTC  –  Mar 23, 2026 at 1:00pm UTC
Affected services
Synthflow Dashboard
Synthflow API
End to end calling

Resolved
Mar 23, 2026 at 12:00pm UTC

Subject Line Planned Maintenance: Infrastructure Optimization

What We're Doing: We will be performing routine infrastructure optimization to improve internal routing efficiency and overall system reliability. IP addresses of some public endpoints may change.

When Scheduled Window: March 23d, 13:00–14:00 CET
Expected Actual Impact Duration: 0–5 minutes during the switchover.

Downtime: Up to 5 minutes due to IP address changes and DNS cache invalidation.

Customer-facing services: API requests may experience latency spikes, packet drops, or HTTP 502/503 errors during the switchover period.

API behavior: Transient errors expected during the 1–5 minute window. Retry logic with exponential backoff is recommended.

Data & queries: This change does not affect customer data, queries, or runtime behavior.

Other services affected: None

What You Need to Do: If your integration does not already handle transient API errors, we recommend ensuring retry logic is in place before the maintenance window.

Monitoring & Safety: Systems will be actively monitored during the update. Rollback procedures are in place if needed. We expect to complete this well within the scheduled window.