Back to overview
Maintenance

Infrastructure Optimization Maintenance

Feb 04 at 09:00am GMT  –  Feb 04 at 10:00am GMT
Affected services
Synthflow API

Resolved
Feb 04 at 09:00am GMT

What We’re Doing:
We will be performing scheduled infrastructure maintenance to migrate part of production workloads to a new, optimized GKE node pool. This change is based on observed resource utilization and is intended to improve cost efficiency while maintaining current performance and reliability.

When:
Scheduled Window: 02-04-2026, 10:00 AM – 11:00 AM CET
Expected Actual Impact Duration: Minimal; up to 10–15 minutes during the maintenance window

Impact:
Downtime: No planned downtime; brief, intermittent service degradation is possible during pod rescheduling

Customer-facing services:
API services may experience short-lived latency or transient errors

Data & requests:
No data loss expected; requests affected during the migration may need to be retried

API behavior:
API endpoints may return temporary errors during pod restarts

Other services:
All other platform services remain unaffected

What You Need to Do:
No action is required on your end.
If you encounter temporary issues during the maintenance window, please retry after a few minutes. Normal operation will resume once the migration is complete.

Monitoring & Safety:
Systems will be actively monitored throughout the maintenance window.

Rolling restarts will be used to minimize impact.

QA validation will be performed after migration.

Rollback procedures are in place if any issues are detected

Rollback Plan:
If issues are identified before decommissioning the existing node pool:

Deployments will be reverted to the previous node pool configuration.

Pods will be rescheduled back to the original nodes.

QA re-verification will be performed before proceeding further.