Service Incident Report — US Voice Service Disruption
Date: July 6, 2026
Status: Resolved
Summary
On July 6, 2026, our US voice service experienced a brief disruption lasting approximately 18 minutes. During this window, calls to and from US-based voice agents failed to connect. The issue has been fully resolved, and all services have returned to normal operation.
What happened
During planned maintenance on our US infrastructure, a routine cleanup step inadvertently removed a network component that our US telephony service depended on. This severed the connection our call-routing system needed to handle calls, causing them to fail to connect.
Impact
• Duration: Approximately 18 minutes
• Region affected: US only. Our EU and global regions were not affected.
• Effect: Inbound and outbound calls to US voice agents did not connect during the affected window. All EU and global traffic was unaffected.
Resolution
Our engineering team identified the cause quickly and restored the connection, after which calls recovered immediately.
Preventing recurrence
We take reliability seriously and have already begun work to prevent this from happening again, including:
• Reviewing our infrastructure configuration to remove reliance on any undocumented dependencies
• Introducing additional review and safeguards for changes to production systems
• Adopting a stricter decommissioning checklist that verifies real usage before any shared infrastructure is removed
We apologize for any disruption this may have caused and appreciate your understanding. If you have any questions or noticed continued issues, please reach out to our support team.
Resolved
Service Incident Report — US Voice Service Disruption
Date: July 6, 2026
Status: Resolved
Summary
On July 6, 2026, our US voice service experienced a brief disruption lasting approximately 18 minutes. During this window, calls to and from US-based voice agents failed to connect. The issue has been fully resolved, and all services have returned to normal operation.
What happened
During planned maintenance on our US infrastructure, a routine cleanup step inadvertently removed a network component that our US telephony service depended on. This severed the connection our call-routing system needed to handle calls, causing them to fail to connect.
Impact
• Duration: Approximately 18 minutes
• Region affected: US only. Our EU and global regions were not affected.
• Effect: Inbound and outbound calls to US voice agents did not connect during the affected window. All EU and global traffic was unaffected.
Resolution
Our engineering team identified the cause quickly and restored the connection, after which calls recovered immediately.
Preventing recurrence
We take reliability seriously and have already begun work to prevent this from happening again, including:
• Reviewing our infrastructure configuration to remove reliance on any undocumented dependencies
• Introducing additional review and safeguards for changes to production systems
• Adopting a stricter decommissioning checklist that verifies real usage before any shared infrastructure is removed
We apologize for any disruption this may have caused and appreciate your understanding. If you have any questions or noticed continued issues, please reach out to our support team.
Resolved
The issue is now resolved, traffic is flowing again. We will provide an RCA shortly.
Identified
We are experiencing degraded performance on our calling infrastructure in the US cluster. This only affects clusters on the US cluster.